Customer Support - Unexpected Issues
Incident Report for Flowroute
Resolved
This incident has been resolved.
Posted May 08, 2020 - 15:38 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 08, 2020 - 14:25 PDT
Investigating
Customer Support is experiencing unexpected issues with its support site, and phone system. We are working with the 3rd-party vendor to provide a resolution. There is no current ETA. Flowroute's production voice and SMS are not affected.
Posted May 08, 2020 - 14:11 PDT
This incident affected: support.flowroute.com.