Auto-replenishment Charges
Incident Report for Flowroute
Resolved
Our team has reinstated Auto-Replenishments and reverted the erroneous charges for applicable accounts. This incident did NOT affect all accounts. Email notifications have been sent to those accounts that will be receiving refunds. Please allow 5-7 business days for those transactions to be reflected on bank statements.
Posted Nov 09, 2023 - 10:18 PST
Identified
Our team is still investigating the full scope of this event. We expect to be reverting associated auto-replenishment charges that were triggered within the next 48 hours. Those reverted charges may take several business days for the reversal of those transactions to be visible on credit card reports. We thank you for your patience with this as we look to correct the issue that was experienced.
Posted Nov 08, 2023 - 15:00 PST
Update
We are reviewing the incident from yesterday where multiple Auto-Replenishments had been triggered and are working to understand the full scope of the event. We will provide further updates as we collect more information.
Posted Nov 08, 2023 - 08:56 PST
Investigating
We are reviewing the incident from yesterday where multiple Auto-Replenishments had been triggered and are working to understand the full scope of the event. We will provide further updates as we collect more information.
Posted Nov 08, 2023 - 08:55 PST
This incident affected: Manage Portal.